超融合HCI

深信服超融合SANGFOR HCI是面向下一代数据中心的软件定义基础架构,通过虚拟化技术融合计算、存储、网络和安全等资源,并提供运维管理、容灾备份、智能监控等高级特性,帮助用户构建极简、稳定、高性能的云化数据中心基石。
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虚拟机开机异常

更新时间:2025-12-10

虚拟开机失败

索引:

①了解什么是蓝屏
②虚拟机通用配置
③虚拟机资源配置
④安装性能优化工具

 

详细操作步骤说明

虚拟机开机失败(平台)

操作影响说明:无

现象描述
HCI开机失败日志提示内存不足或者CPU核数不够
可能原因
需要开机的虚拟机需要较多的CPU和内存资源,现有环境下的物理机主机无法提供对应的资源
排查思路
1、确认虚拟机的CPU和内存的配置
2、检查集群内所有主机的CPU和内存剩余情况
3、确认虚拟机是否有固定运行位置
4、确认是否可以调整虚拟机配置或者关闭部分虚拟机

 

步骤1:故障关键信息确认

   操作影响说明:无

故障现象拍照、截图保存,并收集故障发生时间,故障前做了什么变更操作(迁移、编辑了虚拟机等)

 

步骤2:确认集群主机计算资源情况和集群存储资源情况

   操作影响说明:无

拍照蓝屏页面,确认蓝屏前是否有更新过软件驱动或系统补丁收集记录拍照蓝屏页面,比如下图

虚拟机开机失败(内部)

   操作影响说明:无

可能原因:
1、分区丢失
2、Windows更新导致
3、三方软件导致
4、系统文件异常
5、磁盘损坏
6、虚拟机中病毒

虚拟机开机失败内部排查思路

1、处理此类问题前,需要先了解客户环境或操作系统是否有变更,收集基础信息后再进行排查,主要需要了解的信息如下:
①环境是否有过变更:机房断电、服务器异常重启等
②虚拟机是否有过配置修改:添加虚拟硬件、磁盘扩容等
③操作系统内部是否有过修改:安装或者更新系统补丁包、安装或更新杀软&安全软件&加密软件等
④是否有重启虚拟机电源:异常断电或强制关闭虚拟机电源等
⑤是否有过其他的变更:升级、打包等

清理回收站不重要文件或删除该存储上不重要虚拟机备份文件或者不重要虚拟机等(删除后需清理回收站)

 

步骤3:记录重要信息:拍照开机失败页面,确认开机失败前是否有更新过软件驱动或系统补丁,是否有做其他变更操作

   操作影响说明:无

收集记录拍照开机失败页面,比如下图的开机进入修复页面

步骤四:确认完基础信息后再进行排查,首先需要确认启动项

   操作影响说明:无

(引导顺序)是否正确,正常派生的虚拟机默认磁盘1为系统盘,若是设置成其他磁盘或光驱,则可能会导致开机后找不到启动项。

步骤5:更换启动模式看是否正常,尝试通过最后一次正确配置、安全模式、修复模式等方式恢复虚拟机;

   操作影响说明:无

若是按一次F8无法进入,可以控制台选择全屏,鼠标点击开机后再将鼠标移动到虚拟机内并点击鼠标,之后连续按F8快捷键即可
由于最后一次正确配置会还原CurrentControlSet的注册表,因此若是通过最后一次正确配置可以启动,再次重启后就可以解决问题。若是通过最后一次正确配置无法恢复,则看步骤四

 

步骤6:尝试使用安全模式恢复虚拟机

   操作影响说明:无

按F8后选择安全模式进入虚拟机,若是安全模式进入不了,可以尝试网络安全模式(可以配置网络)和带命令提示符的安全模式(可以使用CMD)
说明:

1、安全模式的工作原理是在不加载第三方设备驱动程序的情况下启动电脑,使电脑运行在系统最小模式,这样用户就可以方便地检测与修复计算机系统的错误。因此若是安全模式启动正常这基本可以定位就是第三方软件或驱动,以及第三方软件或驱动注入注册表后导致的异常;
2、Windows在安全模式下启动时可以自动修复注册表问题,在安全模式下启动Windows成功后,一般就可以在正常模式(Normal)下启动了,因此此时可以直接按正常的启动方式看是否恢复正常;
3、若是按正常启动模式开机依旧不正常,则可以重新进入安全模式。由于Windows操作系统只加载最基本的驱动程序,这样杀起病毒来就更彻底、更干净,因此可以尝试在安全模式下杀毒看是否是系统存在病毒导致。

 

步骤7:尝试进修复模式修复虚拟机

   操作影响说明:无

编辑虚拟机取消fastio后直接开机,尝试用windows自带的修复功能修复虚拟机
若是自动修复功能无法修复虚拟机,则尝试按F8手动进入修复模式

 

详细操作如下:
点击下一步,进入系统恢复选项,并且选择windows自带修复工具,然后再次选择下一步;

 

选择启动修复,之后会进入自动修复阶段,等待修复即可;

 

修复完成后选择不发送,然后选择完成;

 

此时提示:windows无法自动修复此计算机,可以不用管,直接点击完成,之后再次选择重新启动看是否正常恢复即可;

 

最后到启动界面需要选择正常启动,不要选择默认的启动修复(推荐)的模式,选择正常启动后等待一段时间后看是否正常进操作系统。

 

步骤8:确认windows系统补丁及软件是否有更新

   操作影响说明:在虚拟机内进行任何操作都前需要给虚拟机打快照

通过第六步的安全模式、最后一次正确配置等方式进入虚拟机

在控制面板->程序->程序和功能->已安装更新中查看最近是否有更新系统补丁包,若是在故障时间点前后有更新,可以尝试卸载补丁后重启虚拟机看是否正常;若是没有更新补丁,或者卸载后依旧不正常,则继续下面内容

确认软件是否有更新
如下图所示,在控制面板->程序->程序和功能中查看是否有故障时间点前后安装的软件(重点关注安全软件、杀毒软件、加密软件、不常用软件等),尝试将异常软件卸载测试看是否正常

尝试禁用非windows的服务和进程;
1、运行msconfig,打开windows的系统设置功能

点击服务选项,隐藏windows服务后,可以手动禁用一些非系统的服务(sangfor相关和windows相关的服务不用禁用,否则可能会导致agent异常或其他异常)

点击启动选项,可以禁用开机自启项,可以将第三方软件禁用后测试,禁用成功后在禁用日期中会显示被禁用的时间

若是上述排查均没解决问题,则需要将排查虚拟机开机后无法进入操作系统过程收集的信息、做过的排查进行整理,之后请联系400客服热线:4006306430

 

配置验证:无

配置可能涉及的关联问题:无