桌面云aDesk

关注
深信服桌面云aDesk方案,是基于超融合架构的新型桌面模式,通过深度整合服务器虚拟化、桌面虚拟化及存储虚拟化,只需桌面云一体机和云终端两种设备,即可实现云平台的快速交付,为用户提供操作体验及软硬件兼容性媲美PC、更安全、更高效的云桌面。
故障案例库
典型场景排查思路

【aDesk】虚拟机安装NVIDIA显卡驱动失败

更新时间:2023-01-05
  • 阅读权限:游客
  • 下载
  • 分享
  • 收藏
所属模块 虚拟机内部 | 虚拟机软件异常
适用版本 通用
问题现象:用户安装 3D驱动失败
驱动程序窗口出现红色字体提示驱动安装失败
1、获取版本信息并确认在匹配范围  包括(虚拟机OS版本、桌面云版本、驱动版信息)
ps: 552版开始,windows7的场景下,用户只能使用Grid11.1版本的平台驱动+452版本的虚拟机驱动

2、检查驱动MD5值是否与正常的驱动文件一致
3、检查控制面板是否有安装其他版本的英伟达驱动,如果有需要卸载再尝试重新安装与之匹配的驱动版本
4、使用DebugView工具打印软件调试日志并保存下来分析,过程如下:

方法:图形化操作
打开软件 -> 打开驱动进入安装流程 -> 驱动安装失败后->点击窗口的save图标,将日志保存到本地

日志分析:日志从后往前分析
图1

图2

ps: 先找到这一段安装失败的报错(见图1部分),从程序安装失败日志,接着往上分析(见图2部分)
(1)找到一个error,记录的是语法错误。
(2)再往上, Getting previous driver failed. Failing installation   加载驱动失败
(3)再往上,Previous driver installed using, INF name:  C:\Windows\INF\oem45.inf.  (翻译是加载以前的驱动)

失败分析:日志从前往后梳理
加载 C:\Windows\INF\oem45.inf 这个文件失败导致安装程序报了 Install failed ,错误代码 0x800f0003 ,随后终止了程序安装。

原因分析:
1、驱动程序校验过MD5值之后与网盘的驱动一致,说明驱动是正常的。
2、一般的驱动安装会依赖INF文件,而日志里的刚好有加载这个文件的报错,推测可能是环境问题影响了这个文件或者其他原因导致用户的环境文件异常了。

原因论证方法:
1、尝试删除文件 C:\Windows\INF\oem45.inf. 再重新安装 如果成功安装说明就是此文件导致 。

ps: 删除前请对虚拟机执行快照操作~
关于inf文件说明:
https://baike.baidu.com/item/inf%E6%96%87%E4%BB%B6/9028298
环境影响


删除报错的文件解决
1、删除一些系统级的文件建议提前备份和快照,并提前告知用户风险确认后操作。

DebugView.zip

(217.36 KB)

本页目录
  • 问题描述
  • 告警信息
  • 有效排查步骤
  • 根因
  • 解决方案
  • 操作影响范围