桌面云aDesk

关注
深信服桌面云aDesk方案,是基于超融合架构的新型桌面模式,通过深度整合服务器虚拟化、桌面虚拟化及存储虚拟化,只需桌面云一体机和云终端两种设备,即可实现云平台的快速交付,为用户提供操作体验及软硬件兼容性媲美PC、更安全、更高效的云桌面。
故障案例库
典型场景排查思路

问题概述:VDC升级失败的可能原因和排查思路概述

更新时间:2023-01-05
  • 阅读权限:游客
  • 下载
  • 分享
  • 收藏
所属模块 升级打包问题 | 升级失败
适用版本 通用
现象描述
1、VDC升级失败,提示:当前版本不符合升级要求
2、VDC升级失败,提示:升级序列号过期
3、VDC升级550以及550之后版本失败,提示:非法升级包
4、VDC升级失败,提示:“软件序列号校验失败,请检查当前计算机/设备能正常访问互联网”
5、VDC升级失败,提示:系统分区剩余空间不符合升级要求
6、VDC升级失败,提示:appsh’ execute failed(appsh执行失败)
7、VDC升级失败,提示解析升级包错误,该升级包为非法升级包!加载升级包失败
这里只是列举小部分升级失败的现象,所有VDC升级失败问题都可以按此方式处理;
可能原因
1、硬件VDC不满足升级条件导致;
2、升级前没有打升级前检测包导致;
3、升级包或升级前检测包不支持对应版本导致;
4、VDC存在定制包或者补丁包未合入导致;
5、升级客户端版本和VDC版本不匹配导致;
6、VDC服务或程序异常导致;
7、升级549及以后版本需要使用6.3之前的升级客户端版本

排查思路
1、确认VDC是软件还是硬件:硬件VDC需要确保磁盘、内存、CPU等都满足升级条件
2、确认VDC是否具备升级条件:从什么版本升级到什么版本,升级前检测包是否需要打或者是否已经打上
3、准备好对应的升级客户端:离线升级需要使用离线升级包
4、通过升级客户端的报错分析升级失败原因:
5、分析是否是已知案例导致的升级失败:
故障现象关键信息确认
1、现象描述:升级失败的现象及详细报错
2、详细的版本信息:升级前后版本(即从什么版本升级到什么版本),是否有定制包或补丁包等
3、VDC基本信息确认:软件VDC还是硬件VDC,是否符合升级条件
4、VDC升级环境信息确认:离线升级还是在线升级,升级客户端是否匹配等

解释:此部分内容面向外部客户(适配L1、渠道、客户),需要外部提供的信息,内部L1层级保障能够将这部分信息收集全面好准确;
本页目录
  • 问题描述
  • 解决方案
  • 操作影响范围