桌面云aDesk

关注
深信服桌面云aDesk方案,是基于超融合架构的新型桌面模式,通过深度整合服务器虚拟化、桌面虚拟化及存储虚拟化,只需桌面云一体机和云终端两种设备,即可实现云平台的快速交付,为用户提供操作体验及软硬件兼容性媲美PC、更安全、更高效的云桌面。
故障案例库
典型场景排查思路

问题概述:软件、业务系统无法使用Ukey可能原因和排查思路概述

更新时间:2025-03-20
  • 阅读权限:游客
  • 下载
  • 分享
  • 收藏
所属模块 外设相关 | U盘、移动硬盘、key
适用版本 通用
现象描述
1、瘦客户机(ARM/X86)接入虚拟机后,Ukey外设在瘦客户机上可以识别,虚拟机的设备管理器中无法识别;
2、PC客户端接入虚拟机后,Ukey外设在PC上可以识别,虚拟机的设备管理器中无法识别;
3、配置白名单接入虚拟机后,Ukey外设在虚拟机的业务系统无法调用;
可能原因
1、USB外设自身异常导致映射失败;
2、虚拟机agent异常,导致策略下发异常;
3、用户对应瘦客户机的ROM版本不正常,导致策略下发异常
4、用户对应的策略组不对或策略组配置异常等问题,导致策略下发异常;
5、USB设备需要配置高级名单才能正常使用;
6、客户端自身环境问题,导致外设无法映射;
7、客户端和USB外设存在兼容性问题导致外设无法映射;
 
排查思路
1、确认是单个客户端异常还是所有客户端都异常;
2、确认USB外设自身是否使用正常;
3、确定虚拟机agent是否正常;
4、若是瘦客户机接入,则检查对应瘦客户机ROM版本是否正常,瘦客户机是否可以识别USB设备;
5、若是PC客户端接入,则确认物理机是否正常识别USB设备,并对比确认设备驱动是否一致;
6、获取USB设备的基本信息(VID、PID、设备型号、设备名称),并检查用户对应的策略组是否正确配置映射名单;
7、登录桌面云兼容性平台查询对应的USB设备是否支持,并确认是否有已知的解决办法或配置指导;
①联系400通过外设兼容性网站协助查询链接
②通过桌面云巡检工具-外设助手工具进行外设进行调优
8、检查用户对应的策略组是否正常下发;
9、检查虚拟机的设备管理器中是否可以正常识别到USB设备:
10、更换瘦客户机或者PC物理机测试,看是否是终端自身异常;
11、获取终端的日志分析USB映射失败的原因;
本页目录
  • 问题描述
  • 解决方案
  • 操作影响范围