建议使用Chrome浏览器访问!
技术支持
互动社区
学习培训
深信服官网
合作伙伴

桌面云aDesk

关注
深信服桌面云aDesk方案,是基于超融合架构的新型桌面模式,通过深度整合服务器虚拟化、桌面虚拟化及存储虚拟化,只需桌面云一体机和云终端两种设备,即可实现云平台的快速交付,为用户提供操作体验及软硬件兼容性媲美PC、更安全、更高效的云桌面。
故障案例库
典型场景排查思路

问题概述:USB外设无法映射到虚拟机内的可能原因和排查思路概述

更新时间:2023-05-09
  • 阅读权限:游客
  • 下载
  • 分享
  • 收藏
所属模块 外设相关
适用版本 通用
现象描述
1、瘦客户机(ARM/X86)接入虚拟机后,USB外设在瘦客户机上可以识别,虚拟机的设备管理器中无法识别;
2、PC客户端接入虚拟机后,USB外设在PC上可以识别,虚拟机的设备管理器中无法识别;
3、配置白名单接入虚拟机后,USB外设在虚拟机的设备管理器中无法识别;
可能原因
1、USB外设自身异常导致映射失败;
2、虚拟机agent异常,导致策略下发异常;
3、用户对应瘦客户机的ROM版本不正常,导致策略下发异常
4、用户对应的策略组不对或策略组配置异常等问题,导致策略下发异常;
5、USB设备需要配置白名单才支持映射;
6、USB设备获取的VID和PID不正确或者存在多个VID和PID;
7、客户端自身环境问题,导致外设无法映射;
8、客户端和USB外设存在兼容性问题导致外设无法映射;

排查思路
1、确认是单个客户端异常还是所有客户端都异常;
2、确认USB外设自身是否使用正常;
3、确定虚拟机agent是否正常;
4、若是瘦客户机接入,则检查对应瘦客户机ROM版本是否正常,瘦客户机是否可以识别USB设备;
5、若是PC客户端接入,则确认物理机是否正常识别USB设备,并对比确认设备驱动是否一致;
6、获取USB设备的基本信息(VID、PID、设备型号、设备名称),并检查用户对应的策略组是否正确配置映射名单;
7、登录桌面云兼容性平台查询对应的USB设备是否支持,并确认是否有已知的解决办法或配置指导,详细点击跳转
8、检查用户对应的策略组是否正常下发;
9、检查虚拟机的设备管理器中是否可以正常识别到USB设备:
10、更换瘦客户机或者PC物理机测试,看是否是终端自身异常;
11、获取终端的日志分析USB映射失败的原因;
无影响
故障现象关键信息确认
1、故障现象描述:
2、故障影响范围:单个客户端异常还是所有客户端都异常
3、USB外设自身是否使用正常:接物理机测试、确认是否需要单独供电等
4、USB设备的详细信息:VID、PID、设备型号、设备名称等
5、设备详细版本信息:VDC和VMP的详细版本信息
6、agent状态及版本、瘦客户机ROM版本是否正常:
7、ARM、X86、PC等终端是否可以识别到USB设备:
8、VDC平台配置是否有异常:用户对应的策略组是否异常,是否启用USB设备
9、虚拟机内设备管理器是否可以识别到USB设备:
10、兼容性平台是否可以查询到此USB设备的推荐配置:

解释:此部分内容面向外部客户(适配L1、渠道、客户),需要外部提供的信息,内部L1层级保障能够将这部分信息收集全面好准确;
本页目录
  • 问题描述
  • 解决方案
  • 操作影响范围
  • 建议与总结